Moodle 3.2 or later requires at least PHP 5.6.5 (currently using version 5.5.30-1+deb.sury.org~precise+1). Some servers may have multiple PHP versions installed, are you using the correct executable?